Forum

Please or Register to create posts and topics.

OLB pastes verses in paragraph style regardless of how it is set up

Hello:

I borrowed this from another subscriber, but my questions was not answered.  When OLB pastes verses into Word, it looks like this:

“3 ¶ Blessed [are] the poor in spirit: for theirs is the kingdom of heaven. 4 Blessed [are] they that mourn: for they shall be comforted. 5 Blessed [are] the meek: for they shall inherit the earth. 6 Blessed [are] they which do hunger and thirst after righteousness: for they shall be filled. 7 Blessed [are] the merciful: for they shall obtain mercy. 8 Blessed [are] the pure in heart: for they shall see God. 9 Blessed [are] the peacemakers: for they shall be called the children of God. 10 Blessed [are] they which are persecuted for righteousness’ sake: for theirs is the kingdom of heaven.” (Matthew 5:3-10)

I want it to look like this:

3 ¶ Blessed [are] the poor in spirit: for theirs is the kingdom of heaven.
4 Blessed [are] they that mourn: for they shall be comforted.
5 Blessed [are] the meek: for they shall inherit the earth.
6 Blessed [are] they which do hunger and thirst after righteousness: for they shall be filled.
7 Blessed [are] the merciful: for they shall obtain mercy.
8 Blessed [are] the pure in heart: for they shall see God.
9 Blessed [are] the peacemakers: for they shall be called the children of God.
10 Blessed [are] they which are persecuted for righteousness’ sake: for theirs is the kingdom of heaven.
I'm not worried about brackets or italics as I built a macro to deal with that.  But I would like for the verses to paste in formatted and in order, rather than in paragraph style (and yes, I have tried to paste using both paragraph and formatted style and it is the same).

I have CD version 5.43 and Windows 10.

DocD

Highlight the verses with the mouse and then copy to the clipboard using ctrl + C. You will get the format shown below (using NIV).

Mt 5:3 "Blessed are the poor in spirit, for theirs is the kingdom of heaven.
Mt 5:4 Blessed are those who mourn, for they will be comforted.
Mt 5:5 Blessed are the meek, for they will inherit the earth.
Mt 5:6 Blessed are those who hunger and thirst for righteousness, for they will be filled.
Mt 5:7 Blessed are the merciful, for they will be shown mercy.
Mt 5:8 Blessed are the pure in heart, for they will see God.
Mt 5:9 Blessed are the peacemakers, for they will be called sons of God.
Mt 5:10 Blessed are those who are persecuted because of righteousness, for theirs is the kingdom of heaven.

As you noted which may be redundant "(and yes, I have tried to paste using both paragraph and formatted style and it is the same)" This is just a guess, but if the problem is on the OLB end of this thing then in the passage window the text may be displayed as a paragraph. So in OLB, at the beginning of the text there should be this symbol "¶", so, as you highlight text, then right click then click on the Copy to Clipboard link, OLB may be bring up a dialogue box asking where you want the text pasted to. The paragraph then is copied into the clipboard then pasting it as a paragraph into Word. What you could try is that in the toolbar there is this symbol "¶". Click on this to change to a "column", then try going through the copy/paste process again.

Now, if this a Microsoft problem, on "Word's" end of this deal, as to why Word is not accepting the paste as a column, I would not be aware of where we could start.

Running the August 24 version, I tried various paste options. I first changed the view to "paragraph" then selected "paragraph" style to copy/paste. Then I unchecked paragraph style, repeat). Then I also deselected paragraph view.

All four times yielded the exact same result.

The "Copy to Clipboard" (F8)  still works the way it is suppose to.  What section of scripture did you select? Try using Psalm 96:1-13 with paragraph style selected and then deselected.

The text selection you use has to have multiple paragraphs. Examples -

John 1: 1-20

Matt 3:1-17

 

Thank you Mr. Martin.